1SUMMARY = "The canonical example of init scripts"
2SECTION = "base"
3DESCRIPTION = "This recipe is a canonical example of init scripts"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
6
7SRC_URI = "file://skeleton \
8	   file://skeleton_test.c \
9	   file://COPYRIGHT \
10	   "
11
12S = "${WORKDIR}"
13
14do_compile () {
15	${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
16}
17
18do_install () {
19	install -d ${D}${sysconfdir}/init.d
20	cat ${WORKDIR}/skeleton | \
21	  sed -e 's,/etc,${sysconfdir},g' \
22	      -e 's,/usr/sbin,${sbindir},g' \
23	      -e 's,/var,${localstatedir},g' \
24	      -e 's,/usr/bin,${bindir},g' \
25	      -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/skeleton
26	chmod a+x ${D}${sysconfdir}/init.d/skeleton
27
28	install -d ${D}${sbindir}
29	install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
30}
31
32RDEPENDS:${PN} = "initscripts"
33
34CONFFILES:${PN} += "${sysconfdir}/init.d/skeleton"
35