1SUMMARY = "Example of how to build an external Linux kernel module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4
5inherit module
6
7SRC_URI = "file://Makefile \
8           file://hello.c \
9           file://COPYING \
10          "
11
12S = "${WORKDIR}"
13
14# The inherit of module.bbclass will automatically name module packages with
15# "kernel-module-" prefix as required by the oe-core build environment.
16
17RPROVIDES_${PN} += "kernel-module-hello"
18