1SUMMARY = "Sysroot poisoning test"
2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
3
4LICENSE = "MIT"
5
6inherit nopackages
7
8# This test confirms that compiling code that searches /usr/include for headers
9# will result in compiler errors.  This recipe should will fail to build and
10# oe-selftest has a test that verifies that.
11do_compile() {
12    bbnote Testing preprocessor
13    echo "int main(int argc, char** argv) {}" | ${CPP} -I/usr/include -
14    bbnote Testing C compiler
15    echo "int main(int argc, char** argv) {}" | ${CC} -x c -I/usr/include -
16    bbnote Testing C++ compiler
17    echo "int main(int argc, char** argv) {}" | ${CC} -x c++ -I/usr/include -
18}
19
20EXCLUDE_FROM_WORLD = "1"
21