1# This recipe is a copy from the oe-core one.
2# It has a lower and invalid version number in order not to be accidentally used by bitbake.
3# It is used for tests that require overlayed recipe files.
4
5SUMMARY = "GNU Aspell spell-checker"
6SECTION = "console/utils"
7
8LICENSE = "LGPLv2 | LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz"
12SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7"
13SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1"
14
15EXCLUDE_FROM_WORLD = "1"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses"
19
20PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
21
22FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
23FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
24FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
25FILES_${PN} = "${bindir}/aspell"
26FILES_libpspell = "${libdir}/libpspell.so.*"
27FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
28
29ARM_INSTRUCTION_SET_armv4 = "arm"
30ARM_INSTRUCTION_SET_armv5 = "arm"
31ARM_INSTRUCTION_SET_armv6 = "arm"
32
33inherit autotools gettext
34