1SUMMARY = "YADRO Firmware update tool"
2DESCRIPTION = "Command line tool for update firmware"
3HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-fwupdate"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit pkgconfig meson
10
11DEPENDS += " \
12    sdbusplus \
13    openssl \
14"
15
16PACKAGECONFIG[obmc-phosphor-image] = "-Dbmc-image-type=obmc-phosphor-image,,,,,intel-platforms"
17PACKAGECONFIG[intel-platforms] = "-Dbmc-image-type=intel-platforms,,,,,obmc-phosphor-image"
18PACKAGECONFIG[reboot-guard-support] = "-Dreboot-guard-support=true,-Dreboot-guard-support=false"
19PACKAGECONFIG[openpower-support] = "-Dopenpower-support=true,-Dopenpower-support=false"
20
21PACKAGECONFIG ??= " obmc-phosphor-image reboot-guard-support "
22PACKAGECONFIG:append_df-openpower = "openpower-support"
23
24SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-fwupdate;branch=master;protocol=https"
25SRCREV = "eea7cadf0a5b49b3b9eb304b67494516469e96af"
26S = "${WORKDIR}/git"
27