1SUMMARY = "OpenBMC NCPLite Check Inventory State Service"
2DESCRIPTION = "OpenBMC NCPLite Check Inventory State Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS:${PN} += "bash"
11
12SRC_URI = " file://inventory-log.sh \
13            file://inventory-log.service \
14          "
15
16do_install() {
17    install -d ${D}${libexecdir}/${BPN}
18    install -m 0755 ${WORKDIR}/inventory-log.sh ${D}${libexecdir}/${BPN}
19
20    install -d ${D}${systemd_system_unitdir}
21    install -m 0644 ${WORKDIR}/inventory-log.service ${D}${systemd_system_unitdir}
22}
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE:${PN} = "inventory-log.service"
26