xref: /openbmc/openbmc/meta-security/recipes-security/redhat-security/redhat-security_1.0.bb (revision edff49234e31f23dc79f823473c9e286a21596c1)
1eb8dc403SDave CobbleySUMMARY = "redhat security tools"
2eb8dc403SDave CobbleyDESCRIPTION = "Tools used by redhat linux distribution for security checks"
3eb8dc403SDave CobbleySECTION = "security"
403907ee1SPatrick WilliamsLICENSE = "GPL-2.0-only"
58b139283SAndrew GeisslerLIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
6eb8dc403SDave Cobbley
7eb8dc403SDave CobbleySRC_URI = "file://find-chroot-py.sh \
8eb8dc403SDave Cobbley           file://find-chroot.sh \
9eb8dc403SDave Cobbley           file://find-elf4tmp.sh \
10eb8dc403SDave Cobbley           file://find-execstack.sh \
11eb8dc403SDave Cobbley           file://find-hidden-exec.sh \
12eb8dc403SDave Cobbley           file://find-nodrop-groups.sh \
13eb8dc403SDave Cobbley           file://find-sh4errors.sh \
14eb8dc403SDave Cobbley           file://find-sh4tmp.sh \
15eb8dc403SDave Cobbley           file://lib-bin-check.sh \
16eb8dc403SDave Cobbley           file://rpm-chksec.sh \
17eb8dc403SDave Cobbley           file://rpm-drop-groups.sh \
18eb8dc403SDave Cobbley           file://selinux-check-devices.sh \
19eb8dc403SDave Cobbley           file://selinux-ls-unconfined.sh"
20eb8dc403SDave Cobbley
21*edff4923SAndrew GeisslerS = "${WORKDIR}/sources"
22*edff4923SAndrew GeisslerUNPACKDIR = "${S}"
23eb8dc403SDave Cobbley
24eb8dc403SDave Cobbleydo_install() {
25eb8dc403SDave Cobbley	install -d ${D}${bindir}
26*edff4923SAndrew Geissler	install -m 0755 ${S}/find-chroot-py.sh    ${D}${bindir}
27*edff4923SAndrew Geissler	install -m 0755 ${S}/find-chroot.sh    ${D}${bindir}
28*edff4923SAndrew Geissler	install -m 0755 ${S}/find-elf4tmp.sh    ${D}${bindir}
29*edff4923SAndrew Geissler	install -m 0755 ${S}/find-execstack.sh    ${D}${bindir}
30*edff4923SAndrew Geissler	install -m 0755 ${S}/find-hidden-exec.sh    ${D}${bindir}
31*edff4923SAndrew Geissler	install -m 0755 ${S}/find-nodrop-groups.sh    ${D}${bindir}
32*edff4923SAndrew Geissler	install -m 0755 ${S}/find-sh4errors.sh    ${D}${bindir}
33*edff4923SAndrew Geissler	install -m 0755 ${S}/find-sh4tmp.sh    ${D}${bindir}
34*edff4923SAndrew Geissler	install -m 0755 ${S}/lib-bin-check.sh    ${D}${bindir}
35*edff4923SAndrew Geissler	install -m 0755 ${S}/rpm-chksec.sh    ${D}${bindir}
36*edff4923SAndrew Geissler	install -m 0755 ${S}/rpm-drop-groups.sh    ${D}${bindir}
37*edff4923SAndrew Geissler	install -m 0755 ${S}/selinux-check-devices.sh    ${D}${bindir}
38*edff4923SAndrew Geissler	install -m 0755 ${S}/selinux-ls-unconfined.sh    ${D}${bindir}
39eb8dc403SDave Cobbley}
40eb8dc403SDave Cobbley
41213cb269SPatrick WilliamsRDEPENDS:${PN} = "file libcap-ng procps findutils"
42