1SUMMARY = "OpenDNSSEC is a policy-based zone signer that automates the process of keeping track of DNSSEC keys and the signing of zones"
2
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b041dbe2da80d4efd951393fbba90937"
5
6DEPENDS = "libxml2 openssl ldns libmicrohttpd jansson libyaml "
7
8SRC_URI = "https://dist.opendnssec.org/source/opendnssec-${PV}.tar.gz \
9           file://libxml2_conf.patch \
10           file://libdns_conf_fix.patch \
11           "
12
13SRC_URI[sha256sum] = "c0a8427de241118dccbf7abc508e4dd53fb75b45e9f386addbadae7ecc092756"
14
15inherit autotools pkgconfig perlnative
16
17EXTRA_OECONF = " --with-libxml2=${STAGING_DIR_HOST}/usr --with-ldns=${STAGING_DIR_HOST}/usr \
18                 --with-ssl=${STAGING_DIR_HOST}/usr  "
19
20CFLAGS += "-fcommon"
21
22PACKAGECONFIG ?= "sqlite3"
23
24PACKAGECONFIG[cunit] = "--with-cunit=${STAGING_DIR_HOST}/usr, --without-cunit,"
25PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}/usr, ,sqlite3, sqlite3"
26PACKAGECONFIG[mysql] = "--with-mysql=yes, , mariadb, mariadb"
27PACKAGECONFIG[readline]  = "--with-readline, --without-readline, readline"
28PACKAGECONFIG[unwind] = "--with-libunwind, --without-libunwind"
29
30do_install:append () {
31    rm -rf ${D}${localstatedir}/run
32}
33
34RDEPENDS:${PN} = "softhsm"
35
36SKIP_RECIPE[opendnssec] ?= "Needs porting to openssl 3.x"
37