1SUMMARY = "low-level tool handling Linux filesystem encryption"
2DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \
3policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \
4For a tool that presents a higher level interface and manages metadata, key \
5generation, key wrapping, PAM integration, and passphrase hashing, see \
6fscrypt (https://github.com/google/fscrypt)."
7HOMEPAGE = "https://github.com/google/fscryptctl"
8SECTION = "base"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRCREV = "7c80c73c084ce9ea49a03b814dac7a82fd7b4c23"
13SRC_URI = "git://github.com/google/fscryptctl.git;branch=master;protocol=https"
14
15S = "${WORKDIR}/git"
16
17do_compile:prepend() {
18    sed -i 's/fscryptctl\.1//g' ${S}/Makefile
19    sed -i 's/install-man//g' ${S}/Makefile
20}
21
22do_install() {
23    oe_runmake DESTDIR=${D} PREFIX=/usr install
24}
25
26RRECOMMENDS:${PN} += "\
27    keyutils \
28    kernel-module-cbc \
29    kernel-module-cts \
30    kernel-module-ecb \
31    kernel-module-xts \
32"
33