1SUMMARY = "fscrypt is a high-level tool for the management of Linux filesystem encryption"
2DESCIPTION = "fscrypt manages metadata, key generation, key wrapping, PAM integration, \
3and provides a uniform interface for creating and modifying encrypted directories. For \
4a small, low-level tool that directly sets policies, see fscryptctl \
5(https://github.com/google/fscryptcl)."
6HOMEPAGE = "https://github.com/google/fscrypt"
7SECTION = "base"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
11# fscrypt depends on go and libpam
12DEPENDS += "go-native libpam"
13
14SRCREV = "7c80c73c084ce9ea49a03b814dac7a82fd7b4c23"
15SRC_URI = "git://github.com/google/fscrypt.git;branch=master;protocol=https"
16
17GO_IMPORT = "import"
18
19inherit go goarch features_check
20
21REQUIRED_DISTRO_FEATURES = "pam"
22
23S = "${WORKDIR}/git"
24
25do_compile() {
26	export GOARCH=${TARGET_GOARCH}
27	export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
28	export GOPATH="${WORKDIR}/git"
29
30	# Pass the needed cflags/ldflags so that cgo
31	# can find the needed headers files and libraries
32	export CGO_ENABLED="1"
33	export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
34	export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
35
36	cd ${S}/src/${GO_IMPORT}
37	oe_runmake
38
39	# Golang forces permissions to 0500 on directories and 0400 on files in
40	# the module cache which prevents us from easily cleaning up the build
41	# directory. Let's just fix the permissions here so we don't have to
42	# hack the clean tasks.
43	chmod -R u+w ${S}/pkg/mod
44}
45
46do_install() {
47	install -d ${D}/${bindir}
48	install ${S}/src/${GO_IMPORT}/bin/fscrypt ${D}/${bindir}/fscrypt
49}
50
51BBCLASSEXTEND = "native nativesdk"
52