1SUMMARY = "Linux encrypted filesystem management tool"
2HOMEPAGE = "http://cryptmount.sourceforge.net/"
3LIC_FILES_CHKSUM = "file://COPYING;beginline=1;endline=4;md5=6e69c425bf32ecf9b1e11d29d146d03d"
4LICENSE = "GPL-2.0-only"
5SRC_URI = "https://sourceforge.net/projects/cryptmount/files/${BPN}/${BPN}-6.2/${BPN}-${PV}.tar.gz"
6
7SRC_URI[sha256sum] = "90cc49fd598d636929c70479b1305f12b011edadf4a54578ace6c0fca8cb5ed2"
8
9inherit autotools-brokensep gettext pkgconfig systemd
10
11EXTRA_OECONF = " --enable-cswap --enable-fsck --enable-argv0switch"
12
13PACKAGECONFIG ?="intl luks gcrypt nls"
14PACKAGECONFIG:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
15
16PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
17PACKAGECONFIG[intl] = "--with-libintl-prefix, --without-libintl-prefix"
18PACKAGECONFIG[gcrypt] = "--with-libgcrypt, --without-libgcrypt, libgcrypt"
19PACKAGECONFIG[luks] = "--enable-luks, --disable-luks, cryptsetup"
20PACKAGECONFIG[nls] = "--enable-nls, --disable-nls, "
21
22SYSTEMD_PACKAGES = "${PN}"
23SYSTEMD_SERVICE:${PN} = "cryptmount.service"
24
25do_install:append () {
26    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
27        install -D -m 0644 ${S}/sysinit/cryptmount.service ${D}${systemd_system_unitdir}/cryptmount.service
28        if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','false','true',d)}; then
29           rm -fr ${D}/usr/lib
30        fi
31    fi
32}
33
34FILES:${PN} += "${systemd_system_unitdir}"
35
36RDEPENDS:${PN} = "libdevmapper"
37