1SUMMARY = "Linux system security checks"
2DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
3SECTION = "security"
4LICENSE = "BSD-3-Clause"
5HOMEPAGE="https://github.com/slimm609/checksec.sh"
6
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=879b2147c754bc040c29e9c3b84da836"
8
9SRCREV = "2753ebb89fcdc96433ae8a4c4e5a49214a845be2"
10SRC_URI = "git://github.com/slimm609/checksec.sh;branch=main;protocol=https"
11
12S = "${WORKDIR}/git"
13
14do_install() {
15    install -d ${D}${bindir}
16    install -m 0755 ${S}/checksec ${D}${bindir}
17}
18
19RDEPENDS:${PN} = "bash openssl-bin binutils findutils file procps"
20
21BBCLASSEXTEND = "native"
22