1SUMMARY = "Linux Kernel Runtime Guard"
2DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
3kernel and detection of security vulnerability exploits against the kernel."
4SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/"
6LICENSE = "GPL-2.0-only"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=57534ed9f03a5810945cd9be4a81db41"
9
10DEPENDS = "virtual/kernel elfutils"
11
12SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main"
13
14SRCREV = "5dc5cfea1f4dc8febdd5274d99e277c17df06acc"
15
16S = "${WORKDIR}/git"
17
18inherit module kernel-module-split
19
20MAKE_TARGETS = "modules"
21
22MODULE_NAME = "lkrg"
23
24do_configure:append () {
25    sed -i -e 's/^all/modules/' ${S}/Makefile
26    sed -i -e 's/^install/modules_install/' ${S}/Makefile
27    sed -i -e 's/KERNEL/KERNEL_SRC/g' ${S}/Makefile
28}
29
30module_do_install() {
31    install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
32    install -m 0644 ${MODULE_NAME}.ko \
33    ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
34}
35
36RPROVIDES:${PN} += "kernel-module-lkrg"
37
38COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
39