1SUMMARY = "Tripwire: A system integrity assessment tool (IDS)"
2DESCRIPTION = "Open Source Tripwire® software is a security and data \
3integrity tool useful for monitoring and alerting on specific file change(s) on a range of systems"
4HOMEPAGE="http://sourceforge.net/projects/tripwire"
5SECTION = "security Monitor/Admin"
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1c069be8dbbe48e89b580ab4ed86c127"
8
9SRCREV = "6e64a9e5b70a909ec439bc5a099e3fcf38c614b0"
10
11SRC_URI = "\
12	git://github.com/Tripwire/tripwire-open-source.git;branch=master;protocol=https \
13	file://tripwire.cron \
14	file://tripwire.sh \
15	file://tripwire.txt \
16	file://twcfg.txt \
17	file://twinstall.sh \
18	file://twpol-yocto.txt \
19	file://run-ptest \
20       "
21
22S = "${WORKDIR}/git"
23
24inherit autotools-brokensep update-rc.d ptest
25
26INITSCRIPT_NAME = "tripwire"
27INITSCRIPT_PARAMS = "start 40 S ."
28TRIPWIRE_HOST = "${HOST_SYS}"
29TRIPWIRE_TARGET = "${TARGET_SYS}"
30
31CXXFLAGS += "-fno-strict-aliasing"
32EXTRA_OECONF = "--disable-openssl  --enable-static --sysconfdir=/etc/tripwire"
33
34do_install () {
35    install -d ${D}${libdir} ${D}${datadir} ${D}${base_libdir}
36    install -d ${D}${sysconfdir} ${D}${mandir} ${D}${sbindir}
37    install -d ${D}${sysconfdir}/${PN}
38    install -d ${D}${localstatedir}/lib/${PN} ${D}${localstatedir}/lib/${BPN}/report
39    install -d ${D}${mandir}/man4 ${D}${mandir}/man5 ${D}${mandir}/man8
40    install -d ${D}${docdir}/${BPN} ${D}${docdir}/${BPN}/templates
41    install -d ${D}${sysconfdir}/init.d
42
43    install -m 0755 ${S}/bin/* ${D}${sbindir}
44    install -m 0644 ${S}/lib/* ${D}${base_libdir}
45    install -m 0644 ${S}/lib/* ${D}${localstatedir}/lib/${PN}
46    install -m 0755 ${WORKDIR}/tripwire.cron ${D}${sysconfdir}
47    install -m 0755 ${WORKDIR}/tripwire.sh ${D}${sysconfdir}/init.d/tripwire
48    install -m 0755 ${WORKDIR}/twinstall.sh ${D}${sysconfdir}/${PN}
49    install -m 0644 ${WORKDIR}/twpol-yocto.txt ${D}${sysconfdir}/${PN}/twpol.txt
50    install -m 0644 ${WORKDIR}/twcfg.txt ${D}${sysconfdir}/${PN}
51
52    install -m 0644 ${S}/man/man4/* ${D}${mandir}/man4
53    install -m 0644 ${S}/man/man5/* ${D}${mandir}/man5
54    install -m 0644 ${S}/man/man8/* ${D}${mandir}/man8
55    rm ${D}${mandir}/man*/Makefile*
56    install -m 0644 ${S}/policy/templates/* ${D}${docdir}/${BPN}/templates
57    install -m 0644 ${S}/policy/*txt ${D}${docdir}/${BPN}
58    install -m 0644 ${S}/COPYING ${D}${docdir}/${BPN}
59    install -m 0644 ${S}/TRADEMARK ${D}${docdir}/${BPN}
60    install -m 0644 ${WORKDIR}/tripwire.txt ${D}${docdir}/${BPN}
61}
62
63do_install_ptest:append () {
64	install -d ${D}${PTEST_PATH}/tests
65	cp -a ${S}/src/test-harness/* ${D}${PTEST_PATH}
66	sed -i -e 's@../../../../bin@${sbindir}@'  ${D}${PTEST_PATH}/twtools.pm
67}
68
69FILES:${PN} += "${libdir} ${docdir}/${PN}/*"
70FILES:${PN}-dbg += "${sysconfdir}/${PN}/.debug"
71FILES:${PN}-staticdev += "${localstatedir}/lib/${PN}/lib*.a"
72FILES:${PN}-ptest += "${PTEST_PATH}/tests "
73
74RDEPENDS:${PN} += " perl nano msmtp cronie"
75RDEPENDS:${PN}-ptest = " perl lib-perl perl-modules "
76
77SKIP_RECIPE[tripwire] ?= "Upsteram project appears to be abondoned, fails to build with gcc11"
78