1*b542dec1SPatrick WilliamsSUMMARY = "IBM's Software TPM 2.0"
2*b542dec1SPatrick WilliamsDESCRIPTION = "The software TPM 2.0 is targeted toward application development, \
3*b542dec1SPatrick Williamseducation, and virtualization. \
4*b542dec1SPatrick Williams\
5*b542dec1SPatrick WilliamsThe intent is that an application can be developed using the software TPM. \
6*b542dec1SPatrick WilliamsThe application should then run using a hardware TPM without changes. \
7*b542dec1SPatrick WilliamsAdvantages of this approach: \
8*b542dec1SPatrick Williams* In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \
9*b542dec1SPatrick Williams* Application software errors are easily reversed by simply removing the TPM state and starting over. \
10*b542dec1SPatrick Williams* Difficult crypto errors are quickly debugged by looking inside the TPM."
11*b542dec1SPatrick WilliamsHOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
12*b542dec1SPatrick WilliamsLICENSE = "BSD-2-Clause"
13*b542dec1SPatrick WilliamsSECTION = "securty/tpm"
14*b542dec1SPatrick WilliamsLIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f"
15*b542dec1SPatrick WilliamsLIC_FILES_CHKSUM += "file://LICENSE;md5=c75e465155c42c14154bf6a2acb7347b"
16*b542dec1SPatrick Williams
17*b542dec1SPatrick WilliamsDEPENDS = "openssl"
18*b542dec1SPatrick Williams
19*b542dec1SPatrick WilliamsSRC_URI = "git://git.code.sf.net/p/ibmswtpm2/tpm2;protocol=https;branch=master \
20*b542dec1SPatrick Williams           file://tune-makefile.patch \
21*b542dec1SPatrick Williams           "
22*b542dec1SPatrick WilliamsSRCREV = "5452af422edeff70fcae8ea99dd28a0922051d7b"
23*b542dec1SPatrick Williams
24*b542dec1SPatrick WilliamsUPSTREAM_CHECK_URI = "https://git.code.sf.net/p/ibmswtpm2/tpm2"
25*b542dec1SPatrick Williams
26*b542dec1SPatrick WilliamsS = "${WORKDIR}/git/src"
27*b542dec1SPatrick Williams
28*b542dec1SPatrick WilliamsCFLAGS += "-Wno-error=maybe-uninitialized -DALG_CAMELLIA=ALG_NO"
29*b542dec1SPatrick Williams
30*b542dec1SPatrick Williamsdo_compile () {
31*b542dec1SPatrick Williams   make CC='${CC}'
32*b542dec1SPatrick Williams}
33*b542dec1SPatrick Williams
34*b542dec1SPatrick Williamsdo_install () {
35*b542dec1SPatrick Williams   install -d ${D}/${bindir}
36*b542dec1SPatrick Williams   install -m 0755 tpm_server  ${D}/${bindir}
37*b542dec1SPatrick Williams}
38