1SUMMARY = "The tpm-tools package contains commands to allow the platform administrator the ability to manage and diagnose the platform's TPM."
2DESCRIPTION = " \
3  The tpm-tools package contains commands to allow the platform administrator \
4  the ability to manage and diagnose the platform's TPM.  Additionally, the \
5  package contains commands to utilize some of the capabilities available \
6  in the TPM PKCS#11 interface implemented in the openCryptoki project. \
7  "
8SECTION = "tpm"
9LICENSE = "CPL-1.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=059e8cd6165cb4c31e351f2b69388fd9"
11
12DEPENDS = "libtspi openssl perl-native"
13DEPENDS:class-native = "trousers-native"
14
15SRCREV = "bf43837575c5f7d31865562dce7778eae970052e"
16SRC_URI = " \
17    git://git.code.sf.net/p/trousers/tpm-tools;branch=master \
18    file://tpm-tools-extendpcr.patch \
19    file://04-fix-FTBFS-clang.patch \
20    file://openssl1.1_fix.patch \
21    "
22
23inherit autotools-brokensep gettext
24
25S = "${WORKDIR}/git"
26
27do_configure:prepend () {
28	mkdir -p po
29	mkdir -p m4
30	cp -R po_/* po/
31	touch po/Makefile.in.in
32	touch m4/Makefile.am
33}
34
35BBCLASSEXTEND = "native"
36