1DESCRIPTION = "TPM2 packagegroup for Security"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
4                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6inherit packagegroup
7
8PACKAGES = "packagegroup-security-tpm2"
9
10SUMMARY_packagegroup-security-tpm2 = "Security TPM 2.0 support"
11RDEPENDS_packagegroup-security-tpm2 = " \
12    tpm2-tools \
13    trousers \
14    libtss2 \
15    libtss2-tcti-device \
16    libtss2-tcti-mssim \
17    tpm2-abrmd \
18    tpm2-pkcs11 \
19    cryptsetup-tpm-incubator \
20    "
21
22RDEPENDS_packagegroup-security-tpm2_append_x86 = " tpm2-tcti-uefi"
23RDEPENDS_packagegroup-security-tpm2_append_x86-64 = " tpm2-tcti-uefi"
24