1DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382"
4
5SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406"
6SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4"
7
8SRC_URI += " \
9           file://0001-Make-asyncore-support-optional-for-Python-3.patch \
10"
11
12inherit pypi python_setuptools_build_meta
13
14DEPENDS += " \
15    python3-setuptools-scm-native \
16"
17
18RDEPENDS:${PN} += "\
19    python3-ctypes \
20    python3-fcntl \
21    python3-io \
22    python3-logging \
23    python3-misc \
24    python3-shell \
25    python3-threading \
26"
27