1SUMMARY = "A commandline OMX player for the Raspberry Pi"
2DESCRIPTION = "This player was developed as a testbed for the XBMC \
3Raspberry PI implementation and is quite handy to use standalone"
4HOMEPAGE = "https://github.com/popcornmix/omxplayer"
5SECTION = "console/utils"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9
10DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh libomxil coreutils-native curl-native userland"
11
12PR = "r4"
13
14SRCREV_default = "b4bbef8fac5e8c2ddafa895f98456ba715b39c6b"
15
16# omxplayer builds its own copy of ffmpeg from source instead of using the
17# system's ffmpeg library. This isn't ideal but it's ok for now. We do however
18# want to keep control of the exact version of ffmpeg used instead of just
19# fetching the latest commit on a release branch (which is what the checkout job
20# in Makefile.ffmpeg in the omxplayer source tree does).
21#
22# This SRCREV corresponds to the v4.0.3 release of ffmpeg.
23SRCREV_ffmpeg = "fcbd117df3077bad495e99e20f01cf93737bce76"
24
25SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master \
26           git://github.com/FFmpeg/FFmpeg;branch=release/4.0;protocol=git;depth=1;name=ffmpeg;destsuffix=git/ffmpeg \
27           file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \
28           file://0003-Remove-strip-step-in-Makefile.patch \
29           file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \
30           file://fix-tar-command-with-DIST.patch \
31           file://use-native-pkg-config.patch \
32           file://0005-Don-t-require-internet-connection-during-build.patch \
33           file://0006-Prevent-ffmpeg-configure-compile-race-condition.patch \
34           file://0001-Specify-cc-cxx-and-ld-variables-from-environment.patch \
35           file://cross-crompile-ffmpeg.patch \
36           "
37
38SRC_URI_append = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " file://0001-Fix-build-with-vc4-driver.patch ", "", d)}"
39
40S = "${WORKDIR}/git"
41
42COMPATIBLE_MACHINE = "^rpi$"
43
44def cpu(d):
45    for arg in (d.getVar('TUNE_CCARGS') or '').split():
46        if arg.startswith('-mcpu='):
47            return arg[6:]
48    return 'generic'
49
50export CPU = "${@cpu(d)}"
51
52inherit autotools-brokensep pkgconfig
53
54# This isn't used directly by omxplayer, but applied to Makefile.ffmpeg which
55# runs the ffmpeg configuration
56PACKAGECONFIG ??= ""
57PACKAGECONFIG[samba] = "--enable-libsmbclient,--disable-libsmbclient,samba"
58
59# Needed in ffmpeg configure
60export TEMPDIR = "${S}/tmp"
61
62# Needed in Makefile.ffmpeg
63export HOST = "${HOST_SYS}"
64export WORK = "${S}"
65export FFMPEG_EXTRA_CFLAGS  = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
66export FFMPEG_EXTRA_LDFLAGS  = "${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS}"
67
68# Needed in top Makefile
69
70export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \
71                  -L${STAGING_DIR_HOST}/lib \
72                  -L${STAGING_DIR_HOST}/usr/lib \
73                 "
74export INCLUDES = "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", " -D__GBM__", "", d)} \
75                   -isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \
76                   -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \
77                   -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \
78                   -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \
79                   -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \
80                  "
81export DIST = "${D}"
82
83do_compile() {
84    # Needed for compiler test in ffmpeg's configure
85    mkdir -p tmp
86
87    sed -i 's/--enable-libsmbclient/${@bb.utils.contains("PACKAGECONFIG", "samba", "--enable-libsmbclient", "--disable-libsmbclient", d)}/g' Makefile.ffmpeg
88
89    oe_runmake -f Makefile.ffmpeg
90    oe_runmake -f Makefile.ffmpeg install
91    oe_runmake
92}
93
94do_install() {
95    oe_runmake STRIP='echo skipping strip' dist
96    mkdir -p ${D}${datadir}/fonts/truetype/freefont/
97    install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/
98}
99
100FILES_${PN} = "${bindir}/omxplayer* \
101               ${libdir}/omxplayer/lib*${SOLIBS} \
102               ${datadir}/fonts"
103
104FILES_${PN}-dev += "${libdir}/omxplayer/*.so"
105
106RDEPENDS_${PN} += "bash procps userland"
107