1python __anonymous() {
2    if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
3        msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \
4              "provider of virtual/kernel."
5        raise bb.parse.SkipRecipe(msg)
6}
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
9
10LINUX_VERSION ?= "4.19"
11LINUX_RPI_BRANCH ?= "rpi-4.19.y"
12
13SRCREV = "${AUTOREV}"
14SRC_URI = " \
15    git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_BRANCH} \
16    "
17require linux-raspberrypi.inc
18
19# Disable version check so that we don't have to edit this recipe every time
20# upstream bumps the version
21KERNEL_VERSION_SANITY_SKIP = "1"
22
23LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
24