1DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=268;endline=292;md5=86d10e4bcf4b4014d306dde7c1d2a80d"
6
7SRC_URI = "git://github.com/sarfata/pi-blaster \
8           file://remove-initscript-lsb-dependency.patch \
9           "
10
11S = "${WORKDIR}/git"
12
13SRCREV = "befd8ef36e5066e4d444ef47fe4020787e541248"
14
15inherit update-rc.d autotools
16
17INITSCRIPT_PACKAGES = "${PN}"
18INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
19INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
20
21COMPATIBLE_MACHINE = "^rpi$"
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24