1FILESEXTRAPATHS:append := "${THISDIR}/files:"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
5inherit systemd
6inherit obmc-phosphor-systemd
7
8S = "${WORKDIR}"
9
10SRC_URI = "file://init_once.sh \
11           file://poweroff.sh \
12           file://poweron.sh \
13           file://host-gpio.service \
14           file://host-poweroff.service \
15           file://host-poweron.service"
16
17DEPENDS = "systemd"
18RDEPENDS:${PN} = "bash"
19
20SYSTEMD_PACKAGES = "${PN}"
21SYSTEMD_SERVICE:${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
22
23do_install() {
24    install -d ${D}/${bindir}
25    install -m 0755 ${S}init_once.sh ${D}/${bindir}/
26    install -m 0755 ${S}poweroff.sh ${D}/${bindir}/
27    install -m 0755 ${S}poweron.sh ${D}/${bindir}/
28}
29