1LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit native
5
6DEPENDS += "virtual/phosphor-ipmi-fru-inventory"
7PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
8
9# Put the fru_config in the right place with the right name.
10# Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML.
11do_install:append() {
12  IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config
13  IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config
14  install -d ${IPMI_HOST_DEST}
15  cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml
16}
17