1SUMMARY = "Init PSU inventory"
2DESCRIPTION = "Setup PSU inventory read from PSU"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch systemd
8
9RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils}"
10RDEPENDS:${PN} += "bash"
11
12SYSTEMD_SERVICE:${PN} = "first-boot-set-psu@.service"
13SYSTEMD_SERVICE:${PN} += "first-boot-set-psu@0-2-0x58.service"
14
15SRC_URI = "file://${BPN}.sh file://${BPN}@.service"
16
17S = "${WORKDIR}/sources"
18UNPACKDIR = "${S}"
19do_install() {
20    install -d ${D}${bindir} ${D}${systemd_system_unitdir}
21    install ${BPN}.sh ${D}${bindir}/
22    install -m 644 ${BPN}@.service ${D}${systemd_system_unitdir}/
23}
24