1SUMMARY = "Power Cycle by Hotswap Controller"
2DESCRIPTION = "Power Cycle by Hotswap Controller Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS:${PN} += "bash"
11RDEPENDS:${PN} += "libgpiod-tools"
12
13SRC_URI = " file://hotswap-power-cycle.service \
14            file://tray_powercycle.sh \
15          "
16
17do_install() {
18    install -d ${D}${systemd_system_unitdir}
19    install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir}
20
21    install -d ${D}${bindir}
22    install -m 0755 ${WORKDIR}/tray_powercycle.sh ${D}${bindir}
23}
24
25SYSTEMD_PACKAGES = "${PN}"
26SYSTEMD_SERVICE:${PN} = "hotswap-power-cycle.service"
27
28