1SUMMARY = "Phosphor OpenBMC Quanta GBS System Initialization Service"
2DESCRIPTION = "Phosphor OpenBMC Quanta GBS System Init"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS:${PN} += "bash"
11RDEPENDS:${PN} += "i2c-tools"
12RDEPENDS:${PN} += "jq"
13RDEPENDS:${PN} += "libsystemd"
14
15SRC_URI = "file://gbs-sysinit.sh \
16           file://gbs-gpio-common.sh \
17           file://gbs-sysinit.service \
18          "
19
20do_install () {
21    install -d ${D}${bindir}
22    install -m 0755 ${WORKDIR}/gbs-sysinit.sh ${D}${bindir}/
23
24    install -d ${D}${libexecdir}
25    install -m 0755 ${WORKDIR}/gbs-gpio-common.sh ${D}${libexecdir}/
26
27    install -d ${D}${systemd_system_unitdir}
28    install -m 0644 ${WORKDIR}/gbs-sysinit.service ${D}${systemd_system_unitdir}
29}
30
31SYSTEMD_PACKAGES = "${PN}"
32SYSTEMD_SERVICE:${PN} = "gbs-sysinit.service"
33