1DESCRIPTION = "Report CPLD Version"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8SRC_URI = " file://cpld_version.sh \
9            file://cpld-version.service \
10          "
11
12S = "${WORKDIR}/sources"
13UNPACKDIR = "${S}"
14
15DEPENDS = "systemd"
16RDEPENDS:${PN} = "bash"
17
18SYSTEMD_SERVICE:${PN} = "cpld-version.service"
19
20do_install() {
21    install -d ${D}${bindir}
22    install -m 0755 ${S}/cpld_version.sh ${D}${bindir}/
23
24    install -d ${D}${systemd_system_unitdir}
25    install -m 0644 ${S}/cpld-version.service ${D}${systemd_system_unitdir}
26}
27