1LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
3
4inherit autotools pkgconfig
5inherit systemd
6
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=https;branch=master"
9SRCREV = "08b87370c56ff69df852eca87391ae46c05d437a"
10
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "systemd"
13
14FILES:${PN} += "${bindir}/mac-address"
15
16SYSTEMD_PACKAGES = "${PN}"
17SYSTEMD_SERVICE:${PN} = "mac-address.service"
18
19EXTRA_OECONF = " \
20    SYSTEMD_TARGET="multi-user.target" \
21"
22