1SUMMARY = "PECI PCIe"
2DESCRIPTION = "Gathers PCIe information using PECI \
3and provides it on D-Bus"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
7inherit cmake pkgconfig systemd
8
9SRC_URI = "git://github.com/openbmc/peci-pcie;branch=master;protocol=https"
10
11DEPENDS = "boost sdbusplus libpeci"
12
13PV = "0.1+git${SRCPV}"
14SRCREV = "be1fdbfddb8f753132e781109e72b5f2c64140a2"
15
16S = "${WORKDIR}/git"
17
18SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.PCIe.service"
19
20EXTRA_OECMAKE = "-DYOCTO=1"
21