1SUMMARY = "PECI PCIe"
2DESCRIPTION = "Gathers PCIe information using PECI \
3and provides it on D-Bus"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
6DEPENDS = "boost sdbusplus libpeci"
7SRCREV = "638fa5283449c54d6f6e3d8f1fd3d2a2d9278397"
8PV = "0.1+git${SRCPV}"
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[wait-for-os-standby] = "-Dwait-for-os-standby=enabled,-Dwait-for-os-standby=disabled"
12PACKAGECONFIG[use-rdendpointcfg] = "-Duse-rdendpointcfg=enabled,-Duse-rdendpointcfg=disabled"
13
14SRC_URI = "git://github.com/openbmc/peci-pcie;branch=master;protocol=https"
15
16S = "${WORKDIR}/git"
17SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.PCIe.service"
18
19inherit meson pkgconfig systemd
20
21