1LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
3DEPENDS:prepend = "nodejs-native "
4SRCREV = "e16bb5c35893591eab048ae4ef646a9e5e2f7e94"
5PV = "1.0+git${SRCPV}"
6# This recipe requires online access to build, as it uses NPM for dependency
7# management and resolution.
8PR = "r1"
9
10SRC_URI = "git://github.com/openbmc/phosphor-webui.git;branch=master;protocol=https"
11
12S = "${WORKDIR}/git"
13
14inherit allarch
15
16do_compile () {
17    bbwarn "phosphor-webui is deprecated and has been replaced with webui-vue"
18    cd ${S}
19    rm -rf node_modules
20    npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
21    npm run-script build
22}
23do_install () {
24   # create directory structure
25   install -d ${D}${datadir}/www
26   cp -r ${S}/dist/** ${D}${datadir}/www
27   find ${D}${datadir}/www -type f -exec chmod a=r,u+w '{}' +
28   find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
29}
30
31FILES:${PN} += "${datadir}/www/*"
32