1# This recipe requires online access to build, as it uses NPM for dependency
2# management and resolution.
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8SRC_URI = "git://github.com/openbmc/phosphor-webui.git;branch=master;protocol=https"
9SRCREV = "f59274e8ec337e7f4b135726d6b846fb813d60cb"
10S = "${WORKDIR}/git"
11
12DEPENDS:prepend = "nodejs-native "
13
14inherit allarch
15
16FILES:${PN} += "${datadir}/www/*"
17
18do_compile () {
19    bbwarn "phosphor-webui is deprecated and has been replaced with webui-vue"
20    cd ${S}
21    rm -rf node_modules
22    npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
23    npm run-script build
24}
25
26do_install () {
27   # create directory structure
28   install -d ${D}${datadir}/www
29   cp -r ${S}/dist/** ${D}${datadir}/www
30   find ${D}${datadir}/www -type f -exec chmod a=r,u+w '{}' +
31   find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
32}
33
34