1SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit meson pkgconfig
10inherit obmc-phosphor-dbus-service
11
12RPROVIDES:${PN} += "virtual/obmc-watchdog"
13PROVIDES += "virtual/obmc-watchdog"
14
15DEPENDS += "cli11"
16DEPENDS += "sdbusplus"
17DEPENDS += "sdeventplus"
18DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "phosphor-logging"
20DEPENDS += "systemd"
21
22SRC_URI += "git://github.com/openbmc/phosphor-watchdog;branch=master;protocol=https"
23SRCREV = "0f843a88184391a0a104b20dae0376eb0f42007d"
24S = "${WORKDIR}/git"
25
26EXTRA_OEMESON = " \
27        -Dtests=disabled \
28        "
29
30# Copies config file having arguments for host watchdog
31SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/watchdog/poweron"
32
33# Install the override to set up a Conflicts relation
34SYSTEMD_OVERRIDE:${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
35
36# For now, watching PowerOn is the only usecase
37OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
38
39# This is really a DBUS service but the service name is
40# an argument, so making it this way.
41WATCHDOG_TMPL = "phosphor-watchdog@.service"
42ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
43SYSTEMD_SERVICE:${PN} += "${WATCHDOG_TMPL}"
44
45# To Enable Host Watchdog early during poweron
46SYSTEMD_SERVICE:${PN} += "${ENABLE_WATCHDOG_TMPL}"
47
48WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
49ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
50
51WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}"
52ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
53
54SYSTEMD_LINK:${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
55SYSTEMD_LINK:${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"
56