1HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
2LICENSE = "GPL-2.0-or-later"
3LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
4DEPENDS += "autoconf-archive-native"
5DEPENDS += "systemd"
6SRCREV = "08e854a6c425011d029e4e02241afee5060f15eb"
7PV = "0.1+git${SRCPV}"
8PR = "r1"
9
10SRC_URI = "git://github.com/jk-ozlabs/uart-render-controller;branch=master;protocol=https"
11SRC_URI += "file://uart-render-controller.service"
12
13S = "${WORKDIR}/git"
14SYSTEMD_SERVICE:${PN} += "uart-render-controller.service"
15
16inherit autotools
17inherit pkgconfig
18inherit systemd
19
20do_install:append() {
21    install -d ${D}${systemd_system_unitdir}
22    install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
23}
24
25RDEPENDS:${PN} += "fbterm"
26