1SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7SRCREV = "8290e0f3297a2c5cbaa8d872d5cf8e19166ca177"
8PV = "1.0+git${SRCPV}"
9
10SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git;branch=master;protocol=https"
11
12S = "${WORKDIR}/git"
13
14inherit meson pkgconfig systemd
15
16def get_service(d):
17    return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
18
19SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
20DEPENDS += " \
21    sdbusplus \
22    phosphor-dbus-interfaces \
23    phosphor-logging \
24    libcereal \
25    "
26FILES:${PN}  += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
27FILES:${PN}  += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"
28