1SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
5
6SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
7SRCREV = "9d91a39a3a760358a4c1a5e89fb5ef57d1bd7995"
8
9S = "${WORKDIR}/git"
10
11PV = "1.0+git${SRCPV}"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16inherit cmake pkgconfig systemd
17
18SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.State.Boot.PostCode.service"
19
20DEPENDS += " \
21    sdbusplus \
22    phosphor-dbus-interfaces \
23    phosphor-logging \
24    "
25