1SUMMARY = "Service configuration manager daemon to control the service"
2DESCRIPTION = "Applications must use service manager daemon to configure \
3              phosphor-ipmi-net, bmcweb, obmc-console etc in the system, \
4              instead of directly controlling the same using 'systemd' or \
5              'iptables'."
6HOMEPAGE = "https://github.com/openbmc/service-config-manager"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
9DEPENDS = " \
10    boost \
11    phosphor-logging \
12    sdbusplus \
13    systemd \
14    "
15SRCREV = "d8effd63e885cb755aa44665d833b20f187c0e53"
16PV = "1.0+git${SRCPV}"
17PR = "r1"
18
19SRC_URI = "git://github.com/openbmc/service-config-manager;branch=master;protocol=https"
20
21S = "${WORKDIR}/git"
22SYSTEMD_SERVICE:${PN} = "srvcfg-manager.service"
23
24inherit meson pkgconfig systemd
25