1SUMMARY = "Extract CPU and Memory Inventory from SMSMBIOS Table and PECI"
2DESCRIPTION = "This package parses SMBIOS tables, reads Intel CPU PIROM and PECI and provides a dedicated IPMI blob to receive SMBIOS tables sent from LinuxBoot"
3HOMEPAGE = "http://github.com/openbmc/smbios-mdr"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6DEPENDS += " \
7    boost \
8    systemd \
9    sdbusplus \
10    phosphor-dbus-interfaces \
11    phosphor-logging \
12    "
13SRCREV = "4e1cf09955a2f7d62156fa87822acbd8ad57196e"
14PACKAGECONFIG[smbios-no-dimm] = "-Ddimm-dbus=disabled,-Ddimm-dbus=enabled"
15PACKAGECONFIG[cpuinfo] = "-Dcpuinfo=enabled,-Dcpuinfo=disabled,i2c-tools"
16PACKAGECONFIG[cpuinfo-peci] = "-Dcpuinfo-peci=enabled,-Dcpuinfo-peci=disabled,libpeci"
17PACKAGECONFIG[smbios-ipmi-blob] = "-Dsmbios-ipmi-blob=enabled,-Dsmbios-ipmi-blob=disabled,phosphor-ipmi-blobs"
18PACKAGECONFIG[assoc-trim-path] = "-Dassoc-trim-path=enabled,-Dassoc-trim-path=disabled"
19PV = "1.0+git${SRCPV}"
20PR = "r1"
21
22SRC_URI = "git://github.com/openbmc/smbios-mdr.git;branch=master;protocol=https"
23
24S = "${WORKDIR}/git"
25SYSTEMD_SERVICE:${PN} += "smbios-mdrv2.service"
26SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'cpuinfo', 'xyz.openbmc_project.cpuinfo.service', '', d)}"
27
28inherit meson pkgconfig systemd
29
30FILES:${PN} += "${libdir}/blob-ipmid"
31