1ff075f6eSBrad BishopSUMMARY = "Default settings"
2ff075f6eSBrad BishopPR = "r1"
375f0387bSBrad BishopLICENSE = "Apache-2.0"
46f3f0aa7SBrad BishopLIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5ff075f6eSBrad Bishop
6ff075f6eSBrad Bishopinherit phosphor-settings-manager
779809ea7SJoseph Reynoldsinherit native
8ff075f6eSBrad Bishop
9ff075f6eSBrad BishopSRC_URI += "file://defaults.yaml"
10*7298b247SAllen.WangSRC_URI += "file://host-template.yaml"
11ff075f6eSBrad Bishop
12ff075f6eSBrad BishopPROVIDES += "virtual/phosphor-settings-defaults"
13ff075f6eSBrad Bishop
14ff075f6eSBrad BishopS = "${WORKDIR}"
15ff075f6eSBrad Bishop
16ff075f6eSBrad Bishopdo_install() {
17ff075f6eSBrad Bishop        DEST=${D}${settings_datadir}
18ff075f6eSBrad Bishop        install -d ${DEST}
19ff075f6eSBrad Bishop        install defaults.yaml ${DEST}
20*7298b247SAllen.Wang
21*7298b247SAllen.Wang        for i in ${OBMC_HOST_INSTANCES};
22*7298b247SAllen.Wang        do
23*7298b247SAllen.Wang                cat host-template.yaml | sed "s/{}/${i}/g" >> ${DEST}/defaults.yaml
24*7298b247SAllen.Wang
25*7298b247SAllen.Wang        done
26ff075f6eSBrad Bishop}
27