1SUMMARY = "Virtual Sensors"
2DESCRIPTION = "virtual sensors created from existing sensors and config data"
3HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16DEPENDS += "exprtk"
17
18SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
19SRCREV = "543bf6687779c34f0f495eebae7e1819ced27577"
20S = "${WORKDIR}/git"
21
22SYSTEMD_SERVICE_${PN} = "phosphor-virtual-sensor.service"
23