1SUMMARY = "Virtual Sensors"
2DESCRIPTION = "virtual sensors created from existing sensors and config data"
3HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
6DEPENDS:append = "\
7    exprtk \
8    nlohmann-json \
9    phosphor-dbus-interfaces \
10    phosphor-logging \
11    sdbusplus \
12"
13SRCREV = "83e3ac39fce0317b26cd7419d0d373541fa750da"
14PR = "r1"
15
16SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=https;branch=master"
17
18S = "${WORKDIR}/git"
19SYSTEMD_SERVICE:${PN} = "phosphor-virtual-sensor.service"
20
21inherit meson pkgconfig
22inherit systemd
23