1SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
10
11PACKAGE_BEFORE_PN = "max31785-msl"
12SYSTEMD_PACKAGES = "${PN} max31785-msl"
13
14SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
15SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
16
17DEPENDS += "autoconf-archive-native"
18DEPENDS += " \
19        sdbusplus \
20        sdeventplus \
21        phosphor-dbus-interfaces \
22        phosphor-logging \
23        gpioplus \
24        cli11 \
25        "
26
27
28RDEPENDS_${PN} += "\
29        bash \
30        "
31
32RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
33
34FILES_max31785-msl = "${bindir}/max31785-msl"
35RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
36
37SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
38SRC_URI += "file://70-hwmon.rules"
39SRC_URI += "file://70-iio.rules"
40SRC_URI += "file://start_hwmon.sh"
41
42SRCREV = "7e276658d0a0783eb51303995db1a72daaadc4a2"
43
44S = "${WORKDIR}/git"
45
46do_install_append() {
47
48        install -d ${D}/${base_libdir}/udev/rules.d/
49        install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
50        install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
51
52        install -d ${D}${bindir}
53        install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
54}
55