1# SEL Logger has the ability to monitor and automatically log SEL records for
2# various types of events, but this is disabled by default.  The following
3# flags can be set in a .bbappend to enable specific types of event
4# monitoring:
5#
6#   SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
7#      Monitors and logs SEL records for threshold sensor events
8SUMMARY = "Journal IPMI SEL Logger"
9DESCRIPTION = "Utility to write IPMI SEL records to the journal"
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
12DEPENDS += " \
13  boost \
14  sdbusplus \
15  systemd \
16  "
17SRCREV = "5a18f10751278f3dc6e44a6e3bdf28aa1efb2bef"
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
20PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
21PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
22PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
23PACKAGECONFIG[log-host] = "-Dlog-host=true,-Dlog-host=false,"
24PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
25PACKAGECONFIG[sel-delete] = "-Dsel-delete=true,-Dsel-delete=false"
26PV = "0.1+git${SRCPV}"
27
28SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
29
30S = "${WORKDIR}/git"
31SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
32
33inherit pkgconfig meson systemd
34