1SUMMARY = "Journal IPMI SEL Logger"
2DESCRIPTION = "Utility to write IPMI SEL records to the journal"
3
4# SEL Logger has the ability to monitor and automatically log SEL records for
5# various types of events, but this is disabled by default.  The following
6# flags can be set in a .bbappend to enable specific types of event
7# monitoring:
8#
9#   SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
10#      Monitors and logs SEL records for threshold sensor events
11
12inherit pkgconfig meson systemd
13S = "${WORKDIR}/git"
14
15LICENSE = "Apache-2.0"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
17
18DEPENDS += " \
19  boost \
20  sdbusplus \
21  systemd \
22  "
23
24SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
25SRCREV = "87e3fcf439f2b943272365e1d294984f39bb52b8"
26
27PV = "0.1+git${SRCPV}"
28
29SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
30
31PACKAGECONFIG ??= ""
32PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
33PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
34PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
35PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
36PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
37PACKAGECONFIG[clears-sel] = "-Dclears-sel=true,-Dclears-sel=false"
38