1SUMMARY = "SNMP Manager Configuration"
2DESCRIPTION = "SNMP Manager Configuration."
3HOMEPAGE = "http://github.com/openbmc/phosphor-snmp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6DEPENDS += "systemd"
7DEPENDS += "sdbusplus ${PYTHON_PN}-sdbus++-native"
8DEPENDS += "phosphor-dbus-interfaces"
9DEPENDS += "phosphor-logging"
10DEPENDS += "net-snmp"
11SRCREV = "cab8c5368eda1547b882bfc519704cb06a4cb8af"
12PV = "0.1+git${SRCPV}"
13PR = "r1"
14
15SRC_URI += "git://github.com/openbmc/phosphor-snmp;branch=master;protocol=https"
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig
20inherit python3native
21inherit obmc-phosphor-dbus-service
22
23DBUS_SERVICE:${PN} += "xyz.openbmc_project.Network.SNMP.service"
24