1SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
2DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
5DEPENDS += "libxml-simple-perl-native libjson-perl-native"
6SRCREV = "${MRW_API_SRCREV}"
7PR = "r1"
8
9SRC_URI += "${MRW_API_SRC_URI}"
10
11S = "${WORKDIR}/git"
12
13inherit cpan-base
14inherit mrw-rev
15inherit perlnative
16inherit native
17
18do_install() {
19    perl_version="${@get_perl_version(d)}"
20    install -d ${D}${PERLLIBDIRS:class-native}/site_perl/${perl_version}/mrw
21    install -m 0755 scripts/Targets.pm ${D}${PERLLIBDIRS:class-native}/site_perl/${perl_version}/mrw/Targets.pm
22}
23