1SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
2DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7S = "${WORKDIR}/git"
8
9inherit native
10inherit perlnative
11inherit cpan-base
12inherit mrw-rev
13
14DEPENDS += "libxml-simple-perl-native json-perl-native"
15
16SRC_URI += "${MRW_API_SRC_URI}"
17SRCREV = "${MRW_API_SRCREV}"
18
19do_install() {
20    install -d ${D}${PERLLIBDIRS_class-native}/site_perl/${PERLVERSION}/mrw
21    install -m 0755 scripts/Targets.pm ${D}${PERLLIBDIRS_class-native}/site_perl/${PERLVERSION}/mrw/Targets.pm
22}
23