1SUMMARY = "Miscellaneous OpenBMC functions"
2HOMEPAGE = "https://github.com/openbmc/phosphor-misc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7
8SRC_URI = "git://github.com/openbmc/phosphor-misc"
9SRCREV = "688e9134a83379393ddde6aab0602c64e956153d"
10
11S = "${WORKDIR}/git"
12
13inherit meson
14inherit pkgconfig
15inherit systemd
16
17DEPENDS = "systemd"
18
19PHOSPHOR_MISC_PACKAGES = " \
20    ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-hostname', '${PN}-first-boot-set-hostname', '', d)} \
21    ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-mac', '${PN}-first-boot-set-mac', '', d)} \
22    ${@bb.utils.contains('PACKAGECONFIG', 'http-redirect-awk', '${PN}-http-redirect-awk', '', d)} \
23    ${@bb.utils.contains('PACKAGECONFIG', 'usb-ctrl', '${PN}-usb-ctrl', '', d)} \
24    "
25
26PACKAGES_remove = "${PN}"
27RDEPENDS_${PN}-dev = ""
28
29PACKAGE_BEFORE_PN += "${PHOSPHOR_MISC_PACKAGES}"
30SYSTEMD_PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
31
32PACKAGECONFIG ??= " \
33    first-boot-set-hostname \
34    first-boot-set-mac \
35    http-redirect-awk \
36    usb-ctrl \
37    "
38
39PACKAGECONFIG[first-boot-set-hostname] = "-Dfirst-boot-set-hostname=enabled, -Dfirst-boot-set-hostname=disabled"
40PACKAGECONFIG[first-boot-set-mac] = "-Dfirst-boot-set-mac=enabled, -Dfirst-boot-set-mac=disabled"
41PACKAGECONFIG[http-redirect-awk] = "-Dhttp-redirect=enabled, -Dhttp-redirect=disabled"
42PACKAGECONFIG[usb-ctrl] = "-Dusb-ctrl=enabled, -Dusb-ctrl=disabled"
43
44# first-boot-set-hostname
45FILES_${PN}-first-boot-set-hostname = "${bindir}/first-boot-set-hostname.sh"
46SYSTEMD_SERVICE_${PN}-first-boot-set-hostname = "first-boot-set-hostname.service"
47
48# first-boot-set-mac
49FILES_${PN}-first-boot-set-mac = "${bindir}/first-boot-set-mac.sh"
50SYSTEMD_SERVICE_${PN}-first-boot-set-mac = "first-boot-set-mac@.service"
51
52# http-redirect-awk
53FILES_${PN}-http-redirect-awk = "${bindir}/http-redirect.awk"
54SYSTEMD_SERVICE_${PN}-http-redirect-awk = " \
55    http-redirect@.service \
56    http-redirect.socket \
57    "
58RDEPENDS_${PN}-http-redirect-awk = "${VIRTUAL-RUNTIME_base-utils}"
59
60# usb-ctrl
61FILES_${PN}-usb-ctrl = "${bindir}/usb-ctrl"
62