1SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3               supporting tools for OpenBMC."
4HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit pythonnative
12inherit obmc-phosphor-dbus-service
13inherit phosphor-logging
14inherit phosphor-dbus-yaml
15
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
20DEPENDS += "sdbusplus sdbusplus-native"
21DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
22DEPENDS += "virtual/phosphor-logging-callouts"
23DEPENDS += "phosphor-logging-error-logs-native"
24DEPENDS += "phosphor-logging-native"
25DEPENDS += "libcereal"
26DEPENDS += "sdeventplus"
27
28PACKAGE_BEFORE_PN = "${PN}-test"
29FILES_${PN}-test = "${bindir}/*-test"
30
31PACKAGE_BEFORE_PN += "${PN}-elog"
32FILES_${PN}-elog += "${elog_dir}"
33
34# Package configuration
35LOGGING_PACKAGES = " \
36        ${PN}-base \
37        phosphor-rsyslog-config \
38"
39
40ALLOW_EMPTY_${PN} = "1"
41PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
42SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
43DBUS_PACKAGES = "${LOGGING_PACKAGES}"
44
45FILES_${PN}-base += " \
46        ${bindir}/phosphor-log-manager \
47        ${libdir}/libphosphor_logging.so.* \
48"
49DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
50
51DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
52FILES_phosphor-rsyslog-config += " \
53        ${bindir}/phosphor-rsyslog-conf \
54"
55
56SRC_URI += "git://github.com/openbmc/phosphor-logging"
57SRCREV = "5991389ad6d029f3c2a0662097e10c2f0693c974"
58
59S = "${WORKDIR}/git"
60
61# Do not DEPEND on the specified packages for native build
62# as they will not be available in host machine
63DEPENDS_remove_class-native = " \
64        virtual/phosphor-logging-callouts \
65        sdbus++ \
66        systemd \
67        libcereal \
68        sdeventplus \
69        "
70
71# Do not DEPEND on the specified packages for native SDK build
72# as they will not be available in host machine
73DEPENDS_remove_class-nativesdk = " \
74        virtual/phosphor-logging-callouts \
75        sdbus++-native \
76        libcereal \
77        systemd \
78        phosphor-dbus-interfaces \
79        sdeventplus \
80        "
81
82PACKAGECONFIG ??= "metadata-processing install_scripts"
83
84PACKAGECONFIG[metadata-processing] = " \
85        --enable-metadata-processing, \
86        --disable-metadata-processing, , \
87        "
88
89# Provide a means to enable/disable install_scripts feature
90PACKAGECONFIG[install_scripts] = " \
91        --enable-install_scripts, \
92        --disable-install_scripts, ,\
93        "
94
95PACKAGECONFIG[openpower-pels] = " \
96        --enable-openpower-pel-extension, \
97        --disable-openpower-pel-extension, ,\
98        "
99
100# Enable install_scripts during native and native SDK build
101PACKAGECONFIG_add_class-native = "install_scripts"
102PACKAGECONFIG_add_class-nativesdk = "install_scripts"
103
104# Disable install_scripts during target build
105PACKAGECONFIG_remove_class-target = "install_scripts"
106
107EXTRA_OECONF = " \
108        YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
109        CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
110        "
111
112BBCLASSEXTEND += "native nativesdk"
113