1SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3               supporting tools for OpenBMC."
4HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit pkgconfig meson
11inherit python3native
12inherit obmc-phosphor-dbus-service
13inherit phosphor-logging
14inherit phosphor-dbus-yaml
15
16DEPENDS += "systemd"
17DEPENDS += "${PYTHON_PN}-mako-native"
18DEPENDS += "${PYTHON_PN}-pyyaml-native"
19DEPENDS += "${PYTHON_PN}-native"
20DEPENDS += "${PYTHON_PN}-sdbus++-native"
21DEPENDS += "sdbusplus"
22DEPENDS += "phosphor-dbus-interfaces"
23DEPENDS += "virtual/phosphor-logging-callouts"
24DEPENDS += "libcereal"
25DEPENDS += "sdeventplus"
26DEPENDS += "packagegroup-obmc-yaml-providers"
27
28PACKAGE_BEFORE_PN = "${PN}-test"
29FILES:${PN}-test = "${bindir}/*-test"
30
31# Package configuration
32LOGGING_PACKAGES = " \
33        ${PN}-base \
34        phosphor-rsyslog-config \
35"
36
37ALLOW_EMPTY:${PN} = "1"
38PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
39SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
40DBUS_PACKAGES = "${LOGGING_PACKAGES}"
41USERADD_PACKAGES = "${PN}-base"
42GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
43
44FILES:${PN}-base += " \
45        ${datadir}/dbus-1 \
46        ${bindir}/phosphor-log-manager \
47        ${libdir}/libphosphor_logging.so.* \
48"
49DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
50
51DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
52FILES:phosphor-rsyslog-config += " \
53        ${bindir}/phosphor-rsyslog-conf \
54"
55
56SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
57SRCREV = "7f1b90520caac4cb154cd0887e562e527b7f373d"
58
59S = "${WORKDIR}/git"
60
61PACKAGECONFIG ??= ""
62
63PACKAGECONFIG[openpower-pels] = " \
64        -Dopenpower-pel-extension=enabled, \
65        -Dopenpower-pel-extension=disabled, \
66        nlohmann-json cli11 pldm python3, \
67        python3, \
68        "
69
70EXTRA_OEMESON = " \
71        -Dtests=disabled \
72        -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
73        -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
74        "
75